Entire box losing audio 1.4b

Any thing to do with the transcoding implementation.

Entire box losing audio 1.4b

Postby walker428 » Thu Dec 15, 2011 10:18 pm

I am trying to watch some xvid formated videos. I am using stream and transcode settings on the he 1.4b server, the video starts fine, does the first 10 seconds and then restarts (I think this is because of my slow computer) It finally catches up again and then starts playing but when it gets to the part around where it had cut off to reload, the audio craps out and get horribly out of sync, then stops altogether.

The net result of this is that the entire roku box ( I think i have the old xds) loses all audio, even the sound effects in the menu, until I power cycle the box by removing the plug. Has anyone heard of this happening before? What might I do to correct this?
walker428
 
Posts: 15
Joined: Thu Apr 21, 2011 10:28 pm

Re: Entire box losing audio 1.4b

Postby Jim » Thu Dec 15, 2011 11:09 pm

Can you check the audio bit rate with VLC ? Then try and match it with the VLC_param.txt values.
The Roku box has problems with mismatched audio.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Entire box losing audio 1.4b

Postby walker428 » Thu Dec 15, 2011 11:50 pm

ok managed to get audio back without having to do the power cycle. I have to start another video and let it play then end it when the audio returns. This brings back audio to the entire box. Is the program changing the settings on the entire roku box for sound?

You may be right about the bitrate the vlc param is set to 192 and the video files are set for 128. I will give changing that a try tomorrow to see if that improves it.

it should be "acodec=mp4a,ab=128,samplerate=44100,channels=2}" To match the file correct?
walker428
 
Posts: 15
Joined: Thu Apr 21, 2011 10:28 pm

Re: Entire box losing audio 1.4b

Postby Jim » Fri Dec 16, 2011 12:01 am

You might want to add ,audio-sync} to the end of the string
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm


Return to Transcoding

Who is online

Users browsing this forum: No registered users and 1 guest

cron