Can't access transcoded stream, roku 2 xs, mac mini 10.6

Any thing to do with the transcoding implementation.

Can't access transcoded stream, roku 2 xs, mac mini 10.6

Postby tomj74 » Wed Jul 27, 2011 12:16 pm

Hi there! awesome undertaking. but, can't get it to work! I'm starting to think Roku 2 has some compatibility issues (although I have no roku v1 to test with).

1.4beta channel and server.
snow leopard 10.6
latest VLC
I am able to stream mp4 files with transcode off.
activity in the debug files looks good to me but the roku 2 player never even advances to the "loading" bar (in fact I am still able to move around in the channel nav) and after a long delay I get the 'not http error' dialog.

tried setting up a 1.4beta server on a PC, similar results. FWIW I can't get plex to work either.

here's some choice lines from the debug dump:

...
[0x101e30078] main input debug: `file:///Users/tmcclure/My%20Roku/Live%20Stream/stream2-Link' successfully opened
...
[0x101e30078] main input debug: Buffering 4%
[0x101e30078] main input debug: Buffering 6%
[0x100277ec8] main stream output debug: adding a new sout input (sout_input:0x101e2d620)
[0x100282438] stream_out_transcode stream out debug: creating video transcoding from fcc=`mp4v' to fcc=`h264'
[0x10201b708] main generic debug: looking for decoder module: 32 candidates
[0x101e30078] main input debug: Buffering 8%
[0x10201b708] avcodec generic debug: libavcodec already initialized
[0x10201b708] avcodec generic debug: trying to use direct rendering
[0x101e30078] main input debug: Buffering 10%
[0x101e30078] main input debug: Buffering 12%
[0x101e30078] main input debug: Buffering 14%
[0x101e30078] main input debug: Buffering 16%
[0x101e30078] main input debug: Buffering 18%
[0x10201b708] avcodec generic debug: ffmpeg codec (MPEG-4 Video) started
[0x10201b708] main generic debug: using decoder module "avcodec"
[0x10201b708] main generic debug: TIMER module_need() : 43.967 ms - Total 43.967 ms / 1 intvls (Avg 43.967 ms)
[0x10201c308] main encoder debug: looking for encoder module: 1 candidate
[0x10201c308] x264 encoder debug: version x264 0.115.X
[0x10201c308] main encoder debug: set config option: sout-x264-preset to veryfast
[0x10201c308] main encoder debug: set config option: sout-x264-tune to film
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.1 Cache64
[0x101e30078] main input debug: Buffering 20%
[0x101e30078] main input debug: Buffering 22%
[0x101e30078] main input debug: Buffering 25%
[0x101e30078] main input debug: Buffering 27%
[0x101e30078] main input debug: Buffering 29%
x264 [info]: profile High, level 3.0
[0x10201c308] main encoder debug: using encoder module "x264"
[0x10201c308] main encoder debug: TIMER module_need() : 14.223 ms - Total 14.223 ms / 1 intvls (Avg 14.223 ms)
[0x10201c308] x264 encoder debug: framecount still in libx264 buffer: 0
[0x10201c308] main encoder debug: removing module "x264"
[0x100826908] main generic debug: thread started
[0x100826908] main generic debug: thread (encoder) created at priority 0 (../../../../modules/stream_out/transcode/video.c:277)
[0x101e30078] main input debug: Buffering 31%
...
[0x101e30078] main input debug: Buffering 93%
[0x101e30078] main input debug: Buffering 95%
[0x101e30078] main input debug: Buffering 97%
[0x101e30078] main input debug: Buffering 100%
[0x101e30078] main input debug: Stream buffering done (1225 ms in 127 ms)
[0x101e30078] main input debug: Decoder buffering done in 0 ms
[0x102018108] a52 generic debug: A/52 channels:6 samplerate:48000 bitrate:448000
Last edited by tomj74 on Thu Jul 28, 2011 12:23 pm, edited 1 time in total.
tomj74
 
Posts: 2
Joined: Wed Jul 27, 2011 12:01 pm

Re: Can't access transcoded stream, roku 2 xs, mac mini 10.6

Postby tomj74 » Thu Jul 28, 2011 12:22 pm

Hmm, after some more research it's starting to look like the Roku 2 boxes have a serious problem. Every channel I can find that works by streaming content live from a local server (as opposed to simple http streaming of a pre-encoded video file) seems to work ok on Roku 1 but not on the Roku 2.

PlayOn not working on Roku 2:
http://forums.roku.com/viewtopic.php?f=28&t=41640
http://www.playon.tv/forum/general/gene ... ayon-issue

Plex not working on Roku 2:
http://forums.plexapp.com/index.php/top ... ntry183043

It's affecting the roku 2 XD and the roku 2 XS. Roku seems to be aware of the issue but no timetable on a fix.
tomj74
 
Posts: 2
Joined: Wed Jul 27, 2011 12:01 pm

Re: Can't access transcoded stream, roku 2 xs, mac mini 10.6

Postby jeavis » Thu Aug 04, 2011 2:46 pm

Anyone have new information on this issue?
jeavis
 
Posts: 1
Joined: Sat Jul 30, 2011 3:59 pm

Re: Can't access transcoded stream, roku 2 xs, mac mini 10.6

Postby SandboxManager » Tue Aug 09, 2011 8:27 pm

A PlayOn Channel is on purpose being hindered in working with Roku so I doubt you will get a PlayOn fix nor time table for it. I am not sure about the real reason behind the Plex issues.

But I do know that the Roku2 is using the 4.x software which is alot more strict than the 2.x for the previous Roku boxes against poorly written/formated code/channel. Maybe, some developers got sideswipped by the pre-released 3.x for the Roku box while the Roku2 jumped to 4.x but who knows and you will not get a straight answer from Roku or time table for changes.
SandboxManager
 
Posts: 21
Joined: Sat Sep 18, 2010 6:30 pm


Return to Transcoding

Who is online

Users browsing this forum: No registered users and 1 guest

cron