Stuttering about halfway through any vid file

Any thing to do with the transcoding implementation.

Stuttering about halfway through any vid file

Postby xorcist » Tue Aug 30, 2011 9:02 am

The last couple weeks I've been having an issue with chaneru. All I get is xvids and transcode all of them. Before I was able to transcode 90+ min movies without issue. Now, I can barely stream a 42 minute tv show. Just over halfway it'll pop up a Loading..Please wait screen and just sit there. I look in the Live Stream dir, and I see the files there, but it just lags. It'll take a min or two, and it'll either go, or fall back to the menu.
Here is my vlc config. (running version 1.1.11)
vcodec=h264,threads=4,xvb=1200,xscale=1,xquality=8,xwidth=1280,xheight=720,xfps=30,
venc=x264{preset=veryfast,tune=film},
acodec=mp4a,xab=192,xsamplerate=44100,xchannels=2}

any help is appreciated
xorcist
 
Posts: 5
Joined: Wed Aug 10, 2011 2:13 pm

Re: Stuttering about halfway through any vid file

Postby Jim » Tue Aug 30, 2011 11:16 am

Are you running anything else in the background ?

I noticed you have threads set to 4. Is this a good number for your PC ?
You might try defaulting the threads and set the stream option in the server.

You could try adding audio_sync.
acodec=mp4a,xab=192,xsamplerate=44100,xchannels=2,audio_sync}
Roku stammers if the audio gets too far out.

Can you monitor the files transcoded (.ts) and watch the server as it transfers to see if VLC is keeping up.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Stuttering about halfway through any vid file

Postby xorcist » Tue Aug 30, 2011 9:45 pm

I have 8 gigs of ram, so I don't think thats the issue...right now, it shows im only using 2,56 gigs
4 threads is set because I have a quad core cpu
I noticed that when it lags, there are not more ts files past the one it stops on. Its hit or miss, if it'll catch up, it'll buffer the next 10 or so ts files, or it'll just stop. If I restart the vid, and (painfully) fast forward to where it was, it'll create the ts files. I'll add the audio sync and see if that changes anything
xorcist
 
Posts: 5
Joined: Wed Aug 10, 2011 2:13 pm


Return to Transcoding

Who is online

Users browsing this forum: No registered users and 1 guest

cron