Not Seeing Files on DNS-320 NAS using UPnP

Release 2 with UPnP discovery

Not Seeing Files on DNS-320 NAS using UPnP

Postby mokanman » Fri Nov 01, 2013 12:40 am

I have a DNS-320 NAS with one of the drives set up for UPnP. Chaneru sees the drive and all the folders (the interface allows me to drill all the way down) but does not display the file names within the folders. I have many folders containing MP4 and MP3 files and none of them show up. I'm assuming I have missed a step in either the setup or how to use the Chaneru interface because I can access and play all the files from any Windows PC in the house using VLC though I don't use UPnP for that. I have no clue as to where to start looking for how to resolve this.
mokanman
 
Posts: 6
Joined: Fri Nov 01, 2013 12:14 am

Re: Not Seeing Files on DNS-320 NAS using UPnP

Postby Jim » Fri Nov 01, 2013 2:23 pm

Could you send me a log file ?
How to turn on debug logging
http://www.chaneru.com/forum/viewtopic.php?f=5&t=1607

Get it to the point where you know you should show files.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Not Seeing Files on DNS-320 NAS using UPnP

Postby mokanman » Fri Nov 01, 2013 11:32 pm

I emailed the log file to you. Let me know what you figure out.

Thanks!
mokanman
 
Posts: 6
Joined: Fri Nov 01, 2013 12:14 am

Re: Not Seeing Files on DNS-320 NAS using UPnP

Postby Jim » Sat Nov 02, 2013 8:56 pm

1. The Dlink doesn't supply an icon. Created one to display instead of the UPnP with a question mark.
2. The info returned doesn't provide any resource or protocol data for media items. So had to create something meaningful from what is returned.
3. The Dlink uses "chunked" transfers, which I wasn't handling.

In testing.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Not Seeing Files on DNS-320 NAS using UPnP

Postby mokanman » Sun Nov 03, 2013 1:18 pm

Sent you a log file based on the test. Same problem exists though I like the new Icon for the NAS.
mokanman
 
Posts: 6
Joined: Fri Nov 01, 2013 12:14 am

Re: Not Seeing Files on DNS-320 NAS using UPnP

Postby mokanman » Mon Nov 04, 2013 12:01 am

Initial success! I have sent you another log file as you requested and this one was made with a straight shot coming into the app, selecting the NAS, navigating down through the video folders directly to a video and watching it with no problems. In earlier tests this evening I experienced some problems with NAS timeouts and some problems with the NAS icon not being displayed but don't have any logs with those problems yet. I do have the NAS set up to allow the drives to go dormant after a few minutes (I believe it's 5) of non-use so don't know if the Roku or Chaneru would have a problem waiting for the drive to power up but I don't want to leave the drives running all the time when they are not in use.

I'll be testing more over the next couple of weeks and let you know if I experience any more issues but so far this is looking like a really nice product. I like not having to have a computer turned on to watch videos! The Roku and the NAS combined use far less energy then my living room HTPC does. Woohoo!
mokanman
 
Posts: 6
Joined: Fri Nov 01, 2013 12:14 am

Re: Not Seeing Files on DNS-320 NAS using UPnP

Postby Jim » Mon Nov 04, 2013 9:40 am

When do you get the timeouts ?

Do they occur:
1. When you first start up Chaneru ?
2. Click on the icon ?
3. Click on a folder ?

Could you get a set of folders loaded, let it sit until the drive cycles down and then click a folder ?

I use a six second timeout for all transfers. Maybe I could put in code that the first request should be longer ???
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm


Return to Chaneru 2.0

Who is online

Users browsing this forum: No registered users and 1 guest

cron