What is Server 2.0.12.0 doing when it starts?

Release 2 with UPnP discovery

What is Server 2.0.12.0 doing when it starts?

Postby charliehoward » Sat Dec 07, 2013 4:29 am

After using 1.4b for a couple of years, I just installed version 2 on one Roku device. It successfully connected to the 1.4b Server that was running, but in an effort to be current and follow the instructions, I installed the 2.0.12.0 server and started it. Just below the big white logo box, and above the empty wide thin box, is an ever-changing message reading (at the moment): "Search 45 Notify 0 Http 2 Roku 2 Device 10".

I have no idea what that means and have been unable to find any documentation about it or about the server.

The version 2 app on the Roku device cannot find the version 2 server. It immediately finds the correct computer and lists "Windows Media Server" (which isn't running AFAIK and never has been configured or used). It also shows two DirecTV servers (there's only one in my network) and can show the content on that server, but cannot play it (probably because of DirecTV limitations).

However, the Chaneru version 2 app on the Roku device cannot find the Chaneru version 2 Server on the computer. It can find and use the 1.4b Server (despite the caution at this website to match the app to the server). So, after rebooting the computer, both server versions are running. The difference seems to be that Server 1.4b works with both versions of the app and Server 2.0.12.0 does not work with either version of the app.

What do I have to do to get it to work?

Other questions: what does that ever-growing counter mean (after about 30 minutes, the numbers are up to 91 0 2 2 11 now and still going strong); where is it documented; if it isn't documented, why not; will the Server have to do this every time it starts; will it eventually settle down and actually let the Roku box find, connect to, and use this version 2 sever?

Or did I completely miss something in what seemed to be a trivial installation of the new server: just unzip it to a folder and start it with the -sm parameters?
charliehoward
 
Posts: 18
Joined: Thu Aug 25, 2011 8:59 pm

Re: What is Server 2.0.12.0 doing when it starts?

Postby Jim » Sat Dec 07, 2013 11:54 am

Sever display, "Search 45 Notify 0 Http 2 Roku 2 Device 10"
This is on Chaneru.com under the tab for "Server"

Search, times the server issued a network M_SEARCH command, running counter.
Notify, times something on the net issued a NOTIFY command, reset each search issued.
Http, times something on the net replied to my M_SEARCH, reset each search issued.
Roku, number of Roku boxes detected.
Device, number of devices detected.

This is just some info, so you can see if the UPnP functionality is working on your network.
The server also keeps a list of devices it finds and periodically sends them to any Roku boxes it finds. This speeds up discovery a little.

The version problem:
The app must have found the 2.0 server at one point because the 1.4b version doesn't participate in UPnP discovery. Once discovered, the app keeps a list to try when it starts up. So, it did a direct request to the server on the PC and the 1.4b version replied. This could be good or could be bad. If the IP address or port ever changes or the list gets reset, it won't find it.

You should not be running both versions on the PC at the same time. I just tried it and the 1.4b version is displayed with the name of "Chaneru" and the 2.0 version has whatever name you gave it in the "Options". Both versions functioned.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: What is Server 2.0.12.0 doing when it starts?

Postby charliehoward » Sat Dec 07, 2013 1:24 pm

Thank you Jim, that does help clear things up.

After installing Server 2.0.12.0, I'd stopped the 1.4b Server, so that's when the app must have found 2.0.12.0. However, the app didn't work, and the Roku box rebooted. Afterwards, the app kept saying it couldn't connect to the server. Eventually, I stopped the 2.0.12.0 server and started the 1.4b server. Then, both versions of the app worked.

Next, I started the 2.0.12.0 server while keeping the 1.4b server running, and both versions of the app continued to work. The 2.0.12.0 server apparently took the option settings of the 1.4b server, so both were using the same name. It was during that time I posted my original description of the situation.

After reading your reply, I stopped the 1.4b server and changed the name in the 2.0.12.0 server. The version 2 app still is working, so somewhere along the way, the app and server seem to have sorted things out.

What remains to be seen is what happens after the next time the Roku box and the computer are rebooted. If they still talk to each other, I'll install the version 2 app on the other Roku box.
charliehoward
 
Posts: 18
Joined: Thu Aug 25, 2011 8:59 pm


Return to Chaneru 2.0

Who is online

Users browsing this forum: No registered users and 1 guest

cron