Table Build not working correctly - craps out

Discuss the new server for the mac.

Table Build not working correctly - craps out

Postby baltobikeboi » Tue Jun 28, 2011 1:44 pm

Hi,

First let me say I want to like your channel - but there is a LOT of work needed. There is simply way too many things here that should be built into the set-up (especially in "mac users" worlds) (things like making the symbolic links, for example) but I'm sure you'll get it there. Here's my problem:

After I set the symbolic links then I run the "table build" - it runs asking to click any key and I do and it says "Completed" instantly. That's a little fast for my 20,000 song library I'm thinking. Then I go to check the "My Roku" folder and it's not there - and it won't appear unless I run Chaneru first. So, I run Chaneru and it get Chaneru start up, load a bunch of links, then crap out with "Bus Error". Now it does then "reveal" the "My Roku" folder after Chaneru runs - but that doesn't make sense given it shouldn't (by your instructions anyways) be able to see the songs anyways because they haven't been linked yet. And the count is all wrong - stopping at 139 Artists, 292 albums, and 1014 Songs. Something isn't right about the table build. Any thoughts?

PPC G5 (using the G5 table build, ran the permissions update too on it), running OS 10.5.8, Dual Core 2.75, 4GB RAM

...Wait I just noticed something - you can't "Press any key to continue !" - typically I press "Return" to execute and this is apparently logging me out of terminal perhaps - is that correct? I ran the "table build" in a different folder and got the same results (output and stall) from Chaneru - so the table building isn't happening at all (BTW, checked that the iTunes library is named correctly, it is).

Here is the ini file contents:

[Chaneru]
Version=1.4
Name=ME_THE_USER's Media on Googley
IPadrs=192.168.1.2
Port=0
Trace=0
Audit=0
iTunes_Time=0
iTunes_Path=/Users/ME_THE_USER/Music/iTunes
VLC_Path=
On_error=0
[SlideShow]
SS_period=6
SS_overlay=1
SS_shuffle=0
SS_random=0
SS_music=
[Links]
Dropbox=/Users/ME_THE_USER/Dropbox
Movies=/Users/ME_THE_USER/Movies
iTunes=/Users/ME_THE_USER/Music/iTunes
Pictures=/Users/ME_THE_USER/Pictures
iPhoto=/Users/ME_THE_USER/Pictures/iPhoto Lib
baltobikeboi
 
Posts: 2
Joined: Tue Jun 28, 2011 2:41 am

Re: Table Build not working correctly - craps out

Postby Jim » Wed Jun 29, 2011 9:03 am

One thing, the Chaneru server should run on PPC and build the tables when first started. No need to run table builder.
Try and download the beta version of both the channel and server.
Delete the "My Roku" folder and start over.
If it still fails, run it with traces on and email the trace file to support@chaneru.com
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm


Return to Chaneru MAC server

Who is online

Users browsing this forum: No registered users and 1 guest

cron