Features & Fix

What I need from you to make this a better product

Features & Fix

Postby xier » Sun Mar 27, 2011 12:46 pm

1) Movies and music quick link sorted by alphabet; all the "A" movies listed under "A", etc.
2) Ability to run application as a service; currently using FireDaemon
3) Basic fade between showing pictures
4) Support for subtitles embedded in MP4s; this would be very nice to have
5) When putting cover art for movies in the content folder, don't list the pictures as content.

Fix:

1) %20 entries when disconnecting from a movie, then continue viewing. Example is "Iron%20Man.mp4"
xier
 
Posts: 5
Joined: Sun Mar 27, 2011 11:33 am

Re: Features & Fix

Postby Jim » Mon Mar 28, 2011 5:07 pm

Are you running the beta ?
Requests:
1. Going to wait till I rewrite the user interface.
2. There are many methods to run at start up or as a service. This is up to the individual.
3. This is not under my control (Roku).
4. Roku may implement this but for now I think that if you transcode using VLC, it should show. Please let me know one way or the other.
5. They shouldn't show if using the beta.
Fix:
1. Done, next update for beta.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Features & Fix

Postby xier » Tue Mar 29, 2011 8:51 pm

First, thanks for a great program and the receptive feedback and quick updates for your software! It's very refreshing.

I am running the beta server and beta channel.

Here are my results thus far:

1) The default Chaneru paths for videos on my system is showing as c:\Users/Xier/Videos by default (notice the slashes); it does this with all the pre-programed paths. With the slashes backwards it still works, just strange. If I create a new path to content the slashes are correct.
2) If I leave the default "Videos" profile as C:\Users\Xier\Videos the DVD art doesn't show up as "pictures" but if I change the path to say D:\Videos the pictures show up as content as well. I'm sure this is by design in order for Chaneru to identify picture directories.
3) When using transcoding the request for the location for VLC doesn't come up for transcoding until I want to play a video on the Roku (only happens the first time)
4) Using transcoding does not play embedded MP4 subtitles
5) The progress bar on the Roku, when using transcoding is proportionally off, showing 25% complete when only a few minutes into the movie. This is probably out of your control since it is using VLC as a proxy server for the content.
6) Noticed some visual degradation when using transcoding for my MP4 videos. Again, I'm sure this is out of your control since VLC is driving.

Thanks again for the great program.
xier
 
Posts: 5
Joined: Sun Mar 27, 2011 11:33 am

Re: Features & Fix

Postby xier » Tue Mar 29, 2011 10:10 pm

Update on MP4 artwork.

So apparently if you have a single mis-named .jpg file in the videos directory it turns all of the cover art into "pictures". So I have ~ 40 MP4s I've encoded over the last few days. I have been slowly adding them into my "videos" folder. I had one .JPG that was off by a single character from what the .mp4 was named and that caused the remaining .jpg art files to show as pictures. Once I fixed the name of the .jpg to match the MP4 everything worked just fine.
xier
 
Posts: 5
Joined: Sun Mar 27, 2011 11:33 am

Re: Features & Fix

Postby Jim » Tue Mar 29, 2011 10:22 pm

Thanks !
4. Do the subtitles show if you play the movie on the Roku without transcoding ?
5. I don't know how Roku would know the length of the video ? HLS Live Streaming
6. Have you looked at the VLC_Param.txt file to increase the quality ?

I've mentioned it before but what I would like to do, is to come up with a dialog window that contains all of the pertinent VLC and h264 options. Also have the capability to save the options as a global default or the default for a folder or by movie filename.

Ok, I need to look at the bad jpg name. Thanks for the heads up !
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Features & Fix

Postby Jim » Wed Mar 30, 2011 10:45 am

I have a large folder, 400 dummy movies, info and jpg images that I use for testing. I mislabeled one of the images and now the folder shows the bad image as a photo icon and the movie shows default artwork. I added a cover.jpg to the folder and the movie picked it up.

When I pull a folder list, I segregate by types. Then I scan the media and check if a photo matches. If it does I added it to a icon table and remove it from the pictures. If anything is left, you would get the photo icon displayed.

I don't understand how mislabeling one jpg would force it's usage as global icon ???

Could you send a TOC listing ? support@chaneru.com
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Features & Fix

Postby xier » Thu Mar 31, 2011 8:35 am

4. The Subtitles do not play with or without transcoding. I know the subtitles are there though. If I look at the vidwo from VLC and set the option Video --> Subtitles Track, the subtitles play; this option is not available when transcoding. The subtitles are only embedded not "burned" into the MP4. I use Handbrake to encode my movies and there is an option to either "burn" them or embed them. If I burn them into the encoded movie they are there. It's only when they are only embedded that they don't show nor given an option to view. I would be happy to post a sample MP4 for you to pull down and do testing with.

I sent the TOC to your support email address for review as requested. The video files now match the .jpg cover art so everything is working. Let me know if you need anything further.

Thanks.
xier
 
Posts: 5
Joined: Sun Mar 27, 2011 11:33 am

Re: Features & Fix

Postby Jim » Sun Apr 03, 2011 10:13 am

I got the subtitles to show up when transcoding through VLC.
But this raises the question, Why Roku wont show them since the subtitles are embedded in the movie ?
I do have code to extract artwork and meta data from mp4 and m4v videos. I should be able to extract the subtitles.
But now, how do you turn them on and off. Plus, a movie can have multiple tracks.
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Re: Features & Fix

Postby mrmambo » Mon Apr 04, 2011 7:45 am

Feature:
- Delete: would love the ability to delete files, even if limited to .mp4's (non-live transcoding). We have lots of episodic shows that we watch once; would love to hit * button on remote to bring up contextual menu which included delete.

Fix:
- my iTunes database rebuilds almost everytime I open Chaneru, even if I don't have the I option for table structures (don't really understand that)
- I have to manually choose my server each time at startup on the Roku; a list builds up of previous addresses (I currently have 3, including a duplicate). Perhaps I need to give the Roku a fixed IP rather than dynamic. This confuses my wife, who has to choose "Mark's Media on..." each time it starts.
- Search crashes on me when searching through the Movies; I enter a search term, hit go, and Chaneru crashes and exits back to the Roku home screen.

I'm on a Mac running the beta of the server and player (v1.4, March 28).
mrmambo
 
Posts: 11
Joined: Sun Mar 27, 2011 8:27 am

Re: Features & Fix

Postby Jim » Mon Apr 04, 2011 8:52 am

I've always wanted to stay away from modifying users files but when I rewrite the interface, I guess that is doable.

Could you send me a trace of the start up so I can see what's going on with iTunes ?
Sounds like you need to assign an address to your PC or laptop in the router.
Could you also send me a directory listing of the folder that crashes ?
Jim
Site Admin
 
Posts: 879
Joined: Thu Jul 15, 2010 12:35 pm

Next

Return to Features and suggestions

Who is online

Users browsing this forum: No registered users and 0 guests

cron